All systems operational

To report an outage, please call +1 256 254 5856 and enter customer number 399.

If your request is not urgent, please email tech@lowemill.art.

Suspected network equipment issue

Resolved
Major outage
Started over 1 year ago Lasted about 14 hours

Affected

Internet Connection
Wired (Ethernet) and Wireless (Wi-Fi) Networks
1st Floor
2nd Floor
3rd Floor
Updates
  • Resolved
    Resolved

    This issue is resolved. It was caused by a tripped breaker.

  • Identified
    Identified

    An equipment failure has disconnected portions of Lowe Mill from the network. Almost all areas of Lowe Mill will have degraded or zero connectivity until the equipment is repaired.

  • Investigating
    Investigating

    Some key network equipment at Lowe Mill is not responding. This appears to be causing Internet connectivity problems, though the extent is not yet known.